UCaaS Status Page - mFax Intermittent Inbound Fax Failures – Incident details

All systems operational

mFax Intermittent Inbound Fax Failures

Resolved
Operational
Started about 1 month agoLasted 1 day

Affected

Core Services

Operational from 4:38 PM to 5:43 PM

Ashburn (IAD) Voice

Operational from 4:38 PM to 5:43 PM

Atlanta (ATL) Voice

Operational from 4:38 PM to 5:43 PM

Grand Rapids (GRR) Voice

Operational from 4:38 PM to 5:43 PM

Las Vegas (LAS) Voice

Operational from 4:38 PM to 5:43 PM

Phoenix (PHX) Voice

Operational from 4:38 PM to 5:43 PM

Updates
  • Resolved
    Resolved

    As of 2:58am, July 15, 2025 mfax is showing the implemented fix performed by their telecom provider is successful and all inbound faxes are working as intended. 

     After 24 hours of monitoring with no additional inbound fax failures, This incident is now considered resolved.

  • Monitoring
    Monitoring

    Current Status: A fix has been implemented with successful faxes received.

    Next Steps: We will continue to monitor for the next 24 hours.

    Next Update: 2:35 PM ET June 15, 2025

  • Update
    Update

    What Is Affected: mFax

     

    When It Began: 11:45 AM ET June 14, 2025

     

    Current Status: The vendor is currently investigating.

     

    Next Steps: No action required.

     

    Next Update: 2:35 PM ET June 14, 2025

  • Investigating
    Investigating

    At 11:45 AM ET, the mFax vendor reported a subset of inbound numbers failing with a "no fax tone detected" error. This is due to one of the vendor's upstream telecom providers experiencing intermittent failures.

     

    What Is Affected: mFax

     

    When It Began: 11:45 AM ET June 14, 2025

     

    Current Status: The vendor is currently investigating.

     

    Next Steps: No action required.

     

    Next Update: 1:35 PM ET June 14, 2025