UCaaS Status Page - Avanan/AWS Outage – Incident details

All systems operational

Avanan/AWS Outage

Resolved
Major outage
Started 17 days agoLasted about 7 hours
Updates
  • Resolved
    Resolved

    Resolved

    What Occurred: At 8:30 AM ET on October 10th, 2025, our email filtering service began experiencing significant delays and delivery failures to our client-facing support mailboxes as a result of the widespread AWS US-East-1 outage that morning. This includes support@oit.co, success@oit.co, porting@oit.co, billing@oit.co, sales@oit.co, and compliance@oit.co.

    Who is Affected: All partners and clients attempting to contact OIT support

    When It Began: 8:30 AM ET, 10/20/2025

    Current Status:

    This is considered Resolved.

    AWS and our email filtering service have confirmed full functionality has been restored. We've re-enabled our email filtering service and confirmed inbound emails are being received.

    Next Steps:

    If you submitted a support request via email between 8:30 AM ET and 12:30 PM ET and never received a case confirmation email response, please re-send your email to confirm it was received on our end.

    Next Update: N/A

  • Identified
    Identified

    What Occurred: At 8:30 AM ET, our email filtering service began experiencing significant delays and delivery failures to our client-facing support mailboxes as a result of the widespread AWS US-East-1 outage this morning. This includes support@oit.co, success@oit.co, porting@oit.co, billing@oit.co, sales@oit.co, and compliance@oit.co.

     

    Who is Affected: All partners and clients attempting to contact OIT support.

     

    When It Began: 8:30 AM ET, 10/20/2025

     

    Current Status: We have disabled the email filtering service and restored deliverability to the affected mailboxes as of 12:30 PM ET. We are currently working with our email filtering service's support to complete the delivery of all emails sent to the affected mailboxes during this window.

     

    Workarounds: For urgent requests that were sent during this window that cannot wait until the emails are restored, please re-send the email or call our support at 305-967-6756.

     

    Next Steps: Continuing to work with vendor support to ensure all emails are delivered.

     

    Next Update: We will provide an update when all emails during the affected period are restored.

     

    We appreciate your patience throughout this process. If you need additional support, please contact support@oit.co.