UCaaS Status Page - Cloudflare Outage – Incident details

All systems operational

Cloudflare Outage

Resolved
Operational
Started 2 months agoLasted about 4 hours

Affected

Third Party Services

Partial outage from 7:35 PM to 11:18 PM

mFax

Partial outage from 7:35 PM to 11:18 PM

Updates
  • Resolved
    Resolved
    Notice: Cloudflare Outage What Is Affected: MFax When It Began: 1:30 PM ET June 12, 2025 Current Status: Resolved - Cloudflare identified the cause to be with one of their upstream vendors, who as of 4:00 PM ET has fully restored services on their end. mFax is showing all fax queues are clearing and services have been restored. This incident is now considered Resolved. Next Steps: * Major Incident Report will be available within 48 hours. Next Update: 4:30PM ET June 13, 2025 Operational Services: All
  • Monitoring
    Monitoring
    Cloudflare experienced a broad service outage that affected the mFax service. **What Is Affected:** MFax **When It Began:** 1:30 PM ET June 12, 2025 **Current Status:** As of 3:12 pm ET, Cloudflare is showing services are recovering, while mFax services may still experience intermittent "internal server" error messages until fully restored. **Next Steps:** N/A **Next Update:** 4:30PM ET June 13, 2025