UCaaS Status Page - Inbound CNAM Lookup Intermittently Not Returning Correct CID – Incident details

All systems operational

Inbound CNAM Lookup Intermittently Not Returning Correct CID

Resolved
Degraded performance
Started about 2 months agoLasted 21 days

Affected

Carrier Status

Bandwidth

United States Inbound Calling Services

Updates
  • Resolved
    Resolved

    What Occurred: We have identified that the upstream CNAM database provider is intermittently providing incorrect Caller ID Name information after performing a CNAM dip.
    Who is Affected: All partners and clients.
    When It Began: 9:30 AM ET, 9-15-25
    Current Status: 

    • This is considered Resolved.

    • Bandwidth has informed us that after working with their upstream CNAM database provider they were able to correct the inbound CNAM discrepancies. 

    • We have confirmed we are seeing proper inbound CNAM at this time. 

    Next Steps: 

    • If you continue to experience incorrect inbound CNAM, Bandwidth has requested that any new incorrect inbound CNAM lookups be provided to them.

    • If you have any examples please email support@oit.co and provide the caller number, called number, date and time along with the caller ID that was displayed and what it should have been. 

    Next Update: N/A

  • Identified
    Identified

    What Occurred: We have identified that the upstream CNAM database provider is intermittently providing incorrect Caller ID Name information after performing a CNAM dip.

     

    Who is Affected: All partners and clients.

     

    When It Began: 9:30 AM ET, 9/15/2025

     

    Current Status: Bandwidth has internally escalated this with their engineers as well as with their new upstream CNAM DB provider.

     

    Workarounds: There are no known workarounds at this time.

     

    Next Steps: Bandwidth has requested that any new incorrect inbound CNAM lookups be provided to them. If you have any examples, please email support@oit.co and provide the caller number, called number, date and time, along with the caller ID that was displayed and what it should have been.

     

    Next Update: We will provide an update when new information becomes available.

     

    We appreciate your patience throughout this process. If you need additional support, please contact support@oit.co.

  • Investigating
    Investigating

    What Occurred: We have identified that the upstream CNAM database provider is intermittently providing incorrect Caller ID Name information after performing a CNAM dip.

    Who is Affected: All partners and clients.

    When It Began: 9:30 AM ET, 9/15/2025

    Current Status: Bandwidth has confirmed that the upstream CNAM/LIDB database provider is having a broad issue, and they are investigating internally.

    Workarounds: There are no known workarounds at this time.

    Next Update: We will provide an update when new information becomes available.

    We appreciate your patience throughout this process. If you need additional support, please contact support@oit.co.