UCaaS Status Page - Inbound and Outbound NativeFax Failures – Incident details

Native Fax experiencing major outage

Inbound and Outbound NativeFax Failures

Monitoring
Major outage
Started about 21 hours ago

Affected

Core Services

Major outage from 9:14 PM to 12:00 AM

Native Fax

Major outage from 9:14 PM to 12:00 AM

Updates
  • Monitoring
    UTC
    Monitoring

    What Occurred: At approximately 4:47 PM ET on August 19th, 2026, we became aware that inbound and outbound faxes are failing.

    What is Affected: Inbound and Outbound faxes on the NativeFax platform are failing.

    When it began: August 19th, 2026, at 3:21 PM ET

    Current Status: We have successfully restored service to the port server and are seeing both inbound and outbound faxes completing successfully. We will continue to run tests and monitor to ensure stability.

    Next Update: August 20th, 2026, at 3:30 pm ET

  • Identified
    UTC
    Identified

    What Occurred: At approximately 4:47 PM ET on August 19th, 2026, we became aware that inbound and outbound faxes are failing.

    What is Affected: Inbound and Outbound faxes on the NativeFax platform are failing.

    When it began: August 19th, 2026, at 3:21 PM ET

    Current Status: We have identified the root cause, a failure of the fax port server, and are currently working to restore service.

    Next Update: August 19th, 2026 at 6:00pm ET